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The aim of this study was to introduce free open-source software (OSS) and identify the 
tasks associated with video-supported coaching, rehabilitation and scholarly activities. 
The usability and functional requirements of the candidate OSS have been established 
by user participation in field studies and by the consensus of literature, on- and off-line 
discussion groups, and collaboration with coaches and the scientific community over the 
past decade. The critical analysis focused on functionality, ‘use cases’, ‘user goals’, 
environmental constraints, and covered relative performance testing using various 
collected media formats. Instructional guidelines and insights for the target audience 
were aligned with the use of OSS SMPlayer and VLC media player. Future developments 
are aimed at external playlist customisation, tablet and distributed video delivery. 
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INTRODUCTION: The use of video tools for analysis and augmented coaching is common 
amongst sport professionals, coaches, rehabilitation specialists, sport scientists and sport 
enthusiasts. Access to newer, affordable and increasingly powerful video technology and the 
growing multi-disciplinary audience are contributing to the broadening application contexts of 
video replay use. The early commercial developments of video capture, analysis and replay 
tools for sports contexts (Alderson & Elliott, 2006; Knudson & Morrison, 2002) were aligned 
with Knudson & Morrison’s (2002) model of qualitative analysis (preparation, observation, 
analysis and feedback/intervention). To support the globally growing interest in sport 
contexts, the open source software (OSS) community also developed specialised video 
analysis tools (Bačić & Hume, 2012). In addition, there is also a growing number of free 
generic video player tools that could be also used for ad-hoc analysis and to communicate 
feedback/interventions. The focus of this paper is video replay in augmented coaching 
contexts, utilising two OSS video players candidates: SMPlayer and VLC media player. 
 
METHODS: The investigated usability aspects covering people interacting with technology in 
the context of coaching, rehabilitation and sport science are common to human computer 
interaction (HCI) and software engineering. The target audience comprises of: coaches, 
rehabilitation practitioners, sport scientists, athletes and sport enthusiasts. The functional 
requirements, use case and user goals examples were gathered over the past decade from 
field studies in coaching practice, observations, cross-disciplinary interviews, discussion 
groups (on- and off-line) and two case studies in tennis rehabilitation and golf-coaching 
(ethics approvals: AUTEC No. 06/105 and 12/18). The collected data set, reported in the test 
results, included various formats of video samples collected using the various camera 
equipment and mobile devices. The instructional videos (e.g. VOB, WMV, MKV, and FLV file 
types) have also been included in the usability tests for video coaching and presentation 
purposes. For sport and rehabilitation contexts, both VLC and SMPlayer were able to 
produce replays from the video cameras used in the case studies and coaching practice 
(including FireWire-based Sony DCR-TRV110E-PAL and DCR-TRV8E-PAL; and High-speed 
GoPro Hero 3, Sony HDR-AZ1, and Casio Exilim EX-FH25 and EX-ZR100). The test data 
included video files in a number of formats (DV-AVI, MPEG-2, MPEG-4/H.264 AVC, MOV, 
MKV and MTS), resolutions (DV-AVI 720x516, DVD 720x480, HD 1280x720, Full-HD 
1920x1080), PAL/NTSC 25/30 (or 50/60) fps and high-speed frame rates (i.e. 1000 fps at 
224x64; 480 fps at 224x160; 240 fps at 432x320; and 120 fps at 640x480 and 1280x720). 
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RESULTS: The critical analysis included video coaching functionality groups (Table 1) tested 
on the supplied video data set. Both 32-bit VLC and SMPlayer (www.videolan.org/vlc/ and 
http://smplayer.sourceforge.net/, retrieved on 30 Jan. 2015) were tested on the 64-bit 
Windows 7 and 32-bit Windows XP operating systems (OS).  

Table 1 
Video Players’ Functionality for Coaching, Rehabilitation and Sport Science Contexts 

Functionality 
group 

Use case/user goal examples 
and remarks 

Testing remarks: 
[1] VLC (ver. 2.15) and  
[2] SMPlayer (14.9.0.6690) 

Minimalistic  
start-up steps and  
flexible replay 
initialisation  

Video presentation of learning 
objectives, visual feedback, drawing 
athlete focus on critical features for the 
movement of interest. Start-up via file 
association (e.g. media file double click) 
or ‘drag and drop’ of a video file. 

Supported in [1][2]. 
[1] Graphical User Interface (GUI) start-
up using default mode

N
. 

[2] GUI start-up using the last-file 
replayed mode

I,E
  or according to the 

video file’s last replay settings. 

Interactive replay 
controls, 
customisation and 
instant feedback  

For replays and ad-hoc analysis, 
interactive controls should include:  

 Play/Pause 

 Single frame-step control  

 Repeat video or A-B loop section  

 Variable replay speed control 

 Video feedback of last control action 

 Volume control for individual replay. 

Replay navigation and instant feedback 
of selected controls is displayed as fading 
text or a symbol over video replay 
supported in [1]. 
Configurable default mouse scroll:  
[1] volume control. 
[2] variable speed of video navigation. 

Use of the keyboard 
shortcuts:  

 availability  

 configurability  

Replay on restricted space for mouse 
use e.g. outdoor laptop stands. User 
interaction relying on a touchpad, 
remote controller or keyboard shortcuts. 
The use of the shortcuts may be more 
efficient

I,E
 than mouse/touchpad. 

Keyboard shortcuts supported in [1][2] 
[1] Tools>Preferences>Hotkeys 
[1] Less available shortcuts than in [2] 
(e.g. not supported: A-B loop, media 
zoom and rotate keyboard shortcuts).  
[2] Options>Preferences>Keyboard and mouse 

Flexible GUI 
design including the 
toolbar options:

N,I
 

 configurability and 
control functions 

 customisation of 
common tasks  

Hiding toolbars during the replay allows 
maximised viewing experience and 
utilisation of the available display area 
for multiple simultaneous replays. 
Toggling toolbar visibility may also help 
in directing the presentation focus 
between video content and timeline 
information. 

Toolbar on/off toggle default shortcuts 
(would not auto-adjust optimal window 
size):  
[1] Ctrl+h 
[2] Ctrl+c 
Toolbar configurations: 
[1] Tools>Customize Interface… 
[2] Options>Toolbars>Edit main toolbar 

Real-time filters for 
low resolution and 
customised replay 
contexts:

I,E
 

 zoom control 

 de-interlacing  
(de-combing,  
de-blurring) 

 rotate 

 light and contrast 

 swap  

De-interlaced video filters can produce 
sharper frame view and double the 
frame rate (e.g. Yadif filter x2)

 I,E
.
  

For low resolution video replays, users 
may prefer: zoom in region of interest 
(e.g. grip form); de-interlace and rotate 
views (e.g. for optimal viewing), and to 
eliminate post-production transcoding. 
Some high-speed video replays may 
require interactive adjustments of light, 
colour and contrast settings.  
Swap filter allows comparisons of left-
handed with right-handed technique. 

[1][2] Zoom in/out within active window, 
de-interlace, rotate, light and contrast, 
swap. 
 
[1] Ctrl+e, for Adjustments and Effect 
interactive GUI dialog box. 
 
Zoom in/out:  
[1] Ctrl+e>Video Effects>Crop 
[2] using default shortcuts: e and w. 
Note: [1] and [2] vary in diversity of real-
time filters and features. 

Simultaneous 
replays  

Multiple videos can play simultaneously 
for comparative or other presentation 
purposes.  

[1] Enabled by default 
[2] Options>Preferences>Instances: 
 

Internet access and  
privacy control 

Privacy/security control and eliminating 
redundant processing tasks. 

[1][2] User configurable for computers 
that may be connected to the network. 

Use of the playlists Playlist may represent a mental model 
equivalent to e.g. a PowerPoint slides 
presentation. Playlist file content may 
be updated in the background with on-
line streaming for instantaneous or 
delayed video coaching

I,E
. 

Playlist’s file save and file open functions 
are supported in [1][2]. 
[2] NB: External playlist as a directory 
structure might be more convenient than 
the playlist if the last replay settings of 
individual videos are needed. 
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External playlist 
and  
external control 
concepts. 
 

Organising presentation directory 
structure; automating sequence of 
presentation videos

I,E
; using spread 

sheet organisation containing notes and 
presentation sequence control for 
single or multiple/concurrent replays

I,E
. 

Start up options/command line 
parameters for external playlists

I,E
.  

[2] Managing last replays’ settings
E
.  

Closing all video player’s windows using 
OS shortcuts or batch files

I,E
 e.g. 

taskkill /f /t /im vlc.exe 

Note – expected user profile/skill level for video coaching software adaptation:  
N
 Novice – advanced novice: Relies on pointing device and established presentation routine. Can use and 

configure toolbars and shortcuts. Gaining confidence with common and frequent tasks. 
I
  Intermediate – proficient: Utilises keyboard shortcuts for frequent tasks. Would have low-cognitive load 

associated with video coaching allowing focus on coaching objectives, robust focus/improvisation, fast recovery 
from interference (human or technological nature) and ability to transfer knowledge to new circumstances, 
contexts and technologies.  

E
 Expert: Can perform sustained deep focus and instantaneous task execution (e.g. in coaching or video 

analysis) with little attention to user interaction.  

For professional practice using video replays, it is recommended to gain at least an 
intermediate skill level for at least one video player.  
The observations regarding the utility of frame rates for video coaching and analysis include: 

 25 – 60 fps: Regular frame-rate replays including game strategy; player’s courtside 
manners/court presence; court coverage; posture (and other static critical features); 
kinematic sequence (focusing mostly on the large muscles) and coaching rules adherence 
covering common errors. For coaching tennis serve and golf swing relying on reduced 
video size (e.g. DV streaming and DVD quality), it is recommended to rotate the camera 
by 90° as both VLC and SMPlayer are able to rotate video replays in real-time. 

 120 (or 240) fps: Extending regular frame-rate replays e.g. for the artefacts in augmented 
coaching and analysis beyond human cognitive abilities. Such high frame rates combined 
with relatively large HD (720p) resolution settings are recommended for general coaching 
(e.g. tennis techniques) and may provide video evidence (e.g. recorded technique/critical 
features) associated with injury prevention or performance. Some video encoding formats 
(e.g. HD at 120 fps for GoPro cameras) allow default replays at normal speed rate, while 
at reduced speed or frame-by-frame replays the adjacent frames would not be omitted. 
For replays of high-frame rates in slow-motion speed, most tennis coaches and athletes 
preferred 120 fps over 240 fps due to ‘too slow’ slow-motion effect. 

 480 fps: Suitable for human body and equipment around action zone replays. 

 1000 fps: Suitable for replay analysis of equipment interacting with, for example, a ball 
around the impact zone; or providing evidence of lost distance if maximum velocity of a 
club face is before the impact with the ball. Due to limited resolution and increased 
lightness requirement, it was difficult to observe the impact shock wave through human 
tissue with the available technology in the case studies.  

DISCUSSION: In the context of sport and rehabilitation, multi-user video interaction and user 
goal examples include: communicating coaching objectives; focusing on selected critical 
features; showing elite athletes’ performance; reducing the need for a number of daily warm-
up/demonstrate/cool-down cycles; providing immediate augmented proprioceptive feedback 
and (ad-hoc) analysis as delayed replay feedback on captured motion; reviewing suggested 
lists of interventions; comparing performances; providing evidence beyond athlete’s 
proprioceptive or cognitive abilities; clarifying safe vs. unsafe practice (for injury prevention, 
fear of reinjuries, rehabilitation and return to sport); reviewing strategic game dynamics, 
evidence of fatigue and pathomechanics; and replaying ‘best moments’, umpiring and 
dispute resolutions. Single and peer user-computer interactions may include examples of 
athletic trainers, rehabilitation specialists or sport psychologists using video replay for 
analysis or progressive achievement reviewing, rather than visual coaching of basic motor 
skills. The reported tests for the candidate OSS players were limited to Windows-based 
computers. Both the VLC media player and SMPlayer were also running on Linux. However, 
the VLC player is also available for Mac OS-X (with minor limitations e.g. lack of toolbar 
customisation). Both VLC and SMPlayer can use the external third party codecs or their own 
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set of media codecs that could be updated to follow advancements in media encoding 
technology. For augmented video coaching, qualitative analysis and post-production, users 
may consider OSS alternatives such as VirtualDub, FFmpeg, HandBrake and Kinovea (Bačić 
& Hume, 2012). Regarding backward frame-step navigation, many media encoding schemes 
do not perform well. In such cases, users may consider updating their codecs, transcoding 
files into another video format, or using other video players (e.g. Kinovea). The importance of 
‘user locus control’ related to shortcuts, toolbar and replay customisation is evident when 
learning how to use a new video player. The time invested in configuring the shortcuts to the 
accustomed layout may also help in learning additional features listed in the shortcuts 
configuration table. An external playlists concept may be supported via: (1) a directory 
structure and trimmed videos equivalent to A-B replay, (2) by the advanced use of batch 
files, or (3) more complex integration of batch files reading a spread sheet file (e.g. media 
file, start up instruction parameters and coach’s comments). Before attempting advanced 
implementations of external playlists, users are expected to progress through skill levels and 
gain an understanding of video players’ command line (CL), whose basic concepts are 
transferrable from Windows to Mac OS and Linux. For example, the basic start-up CL 
parameter allows a media file to be opened/played with a specified video player application. 
Additional CL parameters allow advanced users to consider organising a playlist as a series 
of instructions stored in a text file to combine presentations of videos in parallel (e.g. multiple 
instances of player’s windows) and in a specified sequence (e.g. opening the next video after 
the previous video(s) has/have been closed). Furthermore, a CL parameter allowing to start 
a video at a particular position can reduce efforts and resources associated with copying and 
trimming videos. Whether aiming to improve performance, safety, helping with fear of re-
injury, or to accelerate recovery, augmented video evidence represents ‘seeing is believing’ 
for all skill level athletes. 
 
CONCLUSION: The results of the usability study demonstrate that VLC and SMPlayer as 
generic OSS for various video format replays were suitable to support sport and rehabilitation 
contexts. The presented use cases are repeatable and applicable to many related domains. 
Extending a player’s command line parameters would enable advanced use of the external 
playlists; advance video-based presentations; meta-data collection/retrieval; analysis and 
organisation. Furthermore, for the OSS community, implementing macro functionality 
(keyboard, mouse and multi-touch gestures) and inter-process communication for data and 
commands exchange would encourage future development of new functionality, interaction 
paradigms and user interfaces within the contexts of sport and rehabilitation. 
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