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This study investigated the feasibility of using open source software (OSS) to provide 
augmented video coaching, qualitative analysis and media post-production which are 
tasks associated with professional coaching/scholarly activities. Utilised test equipment 
consisted of two video cameras, iPad, Mac-mini, two PC laptops and two desktops of 
various specifications. Free OSS were selected based on the possibility they could 
achieve the tasks. Testing occurred over a period of seven years. Critical analysis 
included OSS functionality mapping to the selected tasks and surrounding activities 
associated with media post-production. Instructional guidelines and their on-line links for 
the target audience were developed with the use of OSS VirtualDub, LongoMatch, 
Kinovea, VLC media player. The utilisation of OSS is feasible for coaching/scholarly 
activities. 
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INTRODUCTION: Video analysis, as a form of augmented coaching, is evident in the 
examples of learning by observing the replays of others or yourself at various skill levels from 
beginner (including sport enthusiasts, recreational/amateur participants) to expert.  Some 
reasons for rejection of technology supported augmented coaching include users’ attitude, 
associated costs and the perception of how utilisation of technology can advance coaching 
practice. While an operating system typically allows a form of video capture and replay (e.g. 
iMovie in Apple’s Mac OS X), the utility of such approaches is typically time consuming, 
lacking specific functionality for video analysis/coaching and requires a degree of computer 
literacy. In contrast, specialist commercial software is generally designed to address such 
functionality and usability gaps associated with the tasks of video coaching, analysis and 
content management. Motivated by factors such as commercial software licensing, time 
consuming migration/reinstallation (e.g. when upgrading a computer or the operating system) 
and overall associated costs, this study starts to answer the question whether a common set 
of augmented video coaching tasks can be solved with free, available, open source software 
(OSS) alternatives. 
The OSS initiative (e.g. www.fsf.org and www.gnu.org/licenses/gpl.html, accessed 28 Jan. 
2012) was established to allow free dissemination and software modifications as opposed to 
commercial software restrictions. The examples of OSS initiatives include: sports oriented 
and universal purpose tools (Table 2) as well as free operating systems (Unix/Linux 
variations multi-boot installation tested in Table 1), whose performance is optimised without 
computational overheads of licensing or other forms of digital content validation. Such on-line 
community driven software development (typically linked to active discussion forums and 
published repositories of previous software versions), is designed to complement and 
integrate with existing software, information/communication infrastructures and to work on 
both new and older hardware, found in coaching scenarios. The OSS investigated in this 
initial study is supporting coaching, academic and video content management user activities. 
The primary focus of this study was the task of video capture (Alderson & Elliott, 2006) taking 
into account observation rigor and requirements for qualitative analysis of human movements 
and video post-editing (Knudson & Morrison, 2002). In summary, the purpose of this study 
was to the feasibility of using OSS to provide augmented video coaching, qualitative analysis 
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and media post-production which are tasks associated with professional coaching/scholarly 
activities. 
 
METHODS: The selection of tasks was aimed to cover common activities for the target 
audience (coaches/scholars). The list of user tasks with associated activities were: 
1. Live capture with delayed replay for the purpose of in-vivo self-coaching, single or 

group coaching.  
2. Real-time and post-match analysis, including video segment annotation/tagging for 

direct access replay, game analysis and overlay drawing. 
3. Video presentation and replay, communicating instruction and feedback. Additional 

functions may include comparisons, annotations and intervention instruction. 
4. Video overlay drawing and annotations for analysis, video presentation and replay. 
5. Video content post-production, including video transcoding, segmentation, cropping, 

filtering (deinterlacing, rotation, etc), adding logos and resizing. 
 
Test equipment (see Table 1) was selected based on the range of electronic devices 
currently easily accessible to coaches and consisted of two video cameras, iPad, Mac-mini, 2 
laptops and two PCs (for post-editing purposes). All computers had 7200 rpm hard disks and 
firewire port(s). In addition to established coaching practice, an on-line search was made for 
the most recent OSS that were likely to enable the completion of the user tasks.  Personal 
experience as an elite tennis coach, combined with the literature review search and studies 
for the first authors‘ PhD, shaped the search strategies for OSS. Tests (task, OSS and 
incremental equipment additions) started in 2005, by the authors and acknowledged 
contributors with more concentrated revisions and updates in 2012. 
 

Table 1 
Utilised test equipment 

#. Item Characteristics / Properties 
1. SONY DCR-TRV110E-PAL; 
   with firewire cables  

PAL/NTSC Digital Video Recording; Connectivity: 
i.Link/firewire; Night vision; Lenses: 37mm 20x zoom. 

2. CASIO Exilim EX-FH25 PAL/NTSC DHTV File transfer: USB or SD card (30 MB/s); 
High-speed video (30,120,240, 420 and 1000 fps and 30-
120, 30-240 fps); File Formats: AVI, JPEG; Lenses: 35mm 
20x zoom; Battery: 4x AA (Ni-MH or Alkaline). 

3. iPad 2; with 
  USB / SD Card reader 

iPad storage capacity: 32GB, Direct file transfer: 
iPad Camera Connection Kit (www.apple.com). 

4. Mac Mini (model 2010) CPU 2.26 GHz Intel Core Duo; DDR3/1067 MHz 8 GB; (P< 
85 W); SD Card reader;OS-X, Win-XP, Ubuntu 11.04, 
Fedora 14. 

5. Laptop #1 CLEVO  Pentium 4, 32-bit, 2GB SODIMM (P<120 W), Win XP, 
Ubuntu 9.10 and Ubuntu 9.04 /32-bit. 

6. Laptop #2 ASUS  64-bit AMD Dual Core, 3GB SODIMM, (P<90 W); 
Removeable battery, Win Vista, Win XP, Ubuntu 9.04/32-bit, 
Ubuntu 10.4/64-bit. 

7. PC #1 Single Core AMD 64-bit 2.4 GHz, 2GB DDR; Win XP.  
8. PC #2 Intel i7 (8-core hyper-threading) 64-bit 2.67 GHZ, 12 GB 

DDR3; Win XP, Win 7, Ubuntu: 9.04/64-bit, 9.10/64 bit, and 
0.10/64-bit.  

9. Portable USB card reader Formats: SD, MicroSD, SONY MS, MS Duo, Micro M2. 
P = Power consumption [Watts], information provided by a manufacturer. 
 
RESULTS: VirtualDub, LongoMatch, Kinovea, VLC media player (see Table 2) were 
selected for task review based on user acceptance and functionality/utility testing matched 
with the task(s) requirements. 
The tasks that were able to be achieved using the available equipment, the specifics of how 
the tasks were achieved, and observations and recommendations for the OSS tested are 
shown in Table 2.  
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Table 2 

Tasks acheived, the specifics of how they were acheived, and observations and 
recommendations for the open source software tested.  

#. OSS - Task # and how tasks were achieved  Observations and recommendations 
1. VirtualDub (Lee, 2010) - Tasks: 1,3,5  
Single click, direct capture program preset activation (via 
Command-line), e.g. for DV Camera (Table 1, Item #1): 
"C:\Program Files\VirtualDub-1.9.11\VirtualDub.exe" /capture 
/capdevice "Microsoft DV Camera and VCR (DirectShow)" /capfile 
"%HOMEPATH%/My Documents\DVCam_capture_.AVI"; 
Capture file using name-auto-index (for athlete performance 
video recording) using the shortcut sequence: F5…capture, 
ESC …stop, ] … next name-auto-indexed file; The 
shortcuts for creation / navigation-selection of name-auto-
indexed files, allowing new or unconditional overwriting of 
existing file: [ , ]; 
Single click, direct replay mode program activation and fast 
direct video segmentation (via command-line pre-loaded 
processing settings), e.g:"C:\Program Files\VirtualDub-
1.9.11\VirtualDub.exe" /s "Video_DirectStreamCopy.vcf";  
Replay and selection fast saving (via Video > Direct stream 
copy); Shortcuts: Home, End … mark selection; [,] … go to 
start, end selection; Space-bar … play/pause,  , … 
single frame reverse/forward play; 
In default start-up, e.g. apply 90° video rotation: Video > 
Filters [Add]: Rotation;  
Save repetitive menu-settings/tasks to VCF file: File > Save 
processing settings. 

MS Windows only. General media 
editing and capturing purpose. Well-
documented help and insights. Fast 
navigation function for task #3. 
Advanced integration flexibility: 
command line interface, external 
software integration, text-based 
instruction scripting, generating 
unattended job queue and its task list 
management. Flexible start-up 
configuration via VCF file for different 
user scenarios. Limited in native 
media formats (as well as opening 
media files). Designed to support 
installation of external filters and add-
on media codecs for extending 
functionality and available media file 
formats. Before video replay 
feedback, coaches should practice 
first post-editing using the shortcuts 
for fast selection, replay and apply 
preconfigured settings for “Direct 
stream copy”. 

2. LongoMatch (Alastruey, 2012) - Tasks: 1,2,3,4,5  
On-line capture (tested in ver. 0.16.9 for MS Windows, not 
available in ver. 0.15.7 for Ubuntu 64-bit) and annotate/tag 
motion events:  
     File > New Project > Live project using a capture device; 
On-line and off-line review and game pattern analysis by 
annotation/tagging into user defined categories;  
Video segment adjustment (View > Analyze Mode), 
annotation/review per player, time-line or user-defined 
categories. 
Basics single frame (per annotation) overlay drawing 
capability. 
CSV project export includes information for 
annotated/tagged e.g. for external viewers’ command-line 
parameters replay of project’s video A-B sequences. 

Cross-platform tool (Windows and 
Linux distributions - Ubuntu, Debian, 
Fedora and OpenSUSE). Generic, 
flexible strategy analysis (team and 
individual) and video annotation 
capabilities. Universal tool covering all 
coaching tasks. Relatively longer time 
to learn compared to tools # 1 and 3. 
Game pattern annotation can be 
viewed in timeline. Basic overlay 
drawing tools. Saved projects keep all 
users’ data while preserving the 
original video. Help documentation not 
included in installation.  

3. Kinovea ("Kinovea," 2011) - Tasks: 1,3,4,5  
Usability focus on coaching tasks (1, 3 and 4) was evident 
by intuitive task completion with a minimal number of steps 
required.  
Advanced annotation capability over video segments (real-
time stop watch, perspective grid, translucent fade-in/out 
drawing elements) and export flexibility (e.g. slow motion 
MKV or standard speed AVI, MPG4, MKV). 

The most intuitive user interface for 
coaching tasks that are also well 
documented. Advanced overlay 
drawing and analysis tools. MS 
Windows only. Separate Microsoft’s 
.NET framework ver. 2 or higher (23 
MB or > 237MB separate download 
for higher .NET versions) required. 

4. VLC media player ("VLC media player," 2011) - Task: 3  
Tests (MS Windows, Linux and Mac OS X): Playing a 
range of commonly used media formats, without additional 
codec libraries installation; 
Configuring shortcut keys: Tools > Preferences [Hotkeys] ; or 
VLC > Preferences …  
Default shortcut keys e.g: e … single frame play; l … loop 
play; Space-bar … play/pause; 
A-B loop button added to user interface View > Customise 

Cross-platform tool, which can play a 
range of commonly used media 
formats, without additional codec 
libraries installation. While video-
streaming capture was achieved, for 
its complexity, it is not recommended 
as practical solution for e.g. coaching 
task #1. For video replay/coaching 
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Interface … (user interface modification is not available in 
ver. 1.0.1 for Mac OS X). 

purpose user should: (1) install the 
latest version of VLC and (2) 
consider alternative players. 

 
DISCUSSION: The increasing presence of OSS represents alternatives for users to try and 
opt for free software, which may not offer the same level of usability and support compared 
to commercial software, while the OSS is often accompanied with discussion forums. 
Regarding preserving data, security and potential installation challenges, it is recommended 
that Linux installation and configuration for novices should be supervised or assisted by at 
least an intermediate or expert Linux user. Re/installation of Linux and basic security 
configuration may take less than 45 minutes. Typical CD installation includes PDF, archiving 
(ZIP) and device driver operation capability as well as an open office software suite. Linux 
distributions can read/write in partitions native to Windows. While this is convenient for 
sharing videos and salvaging (virus-infected/lost password) data, it is also possible to corrupt 
a portion of the Windows file system by creating files using Linux/Mac OS file naming 
conventions. To protect athletes’ privacy users should create (Linux) user accounts with 
encrypted file system for storing and reviewing data or use the third party encryption or 
secure network attached storage devices (typically based on Linux kernel).  
For the coaches, athletes and scientists the following suggestions are associated with the 
VirtualDub tasks. (1) Use filter combination pipeline, compress or transcode video in post-
production rather than during the capture (minimising cognitive load and allowing focus to 
coaching tasks). Decide if convenient to segment video as early as possible or at a later 
stage. Use external codecs and storage devices (relatively inexpensive) and off-load 
transcoding to another computer (e.g. low-power Mac-mini or less frequently used PC). 
Using the task queue function, it is possible for a computer to filter, transcode (in unattended 
fashion) and shut-down when complete. (2) Apply filters first and then transcode at the final 
stage (to minimise quality loss). 
 
CONCLUSION: The feasibility of OSS application was achieved for the tasks associated with 
video coaching, qualitative analysis and post-production or digital content management. In 
response to system upgrades, reinstallation or migration as well as anti-piracy and privacy 
concerns, the utilisation of free software represents a viable alternative.  
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